[戻る]
一括表示

タイトル
記事No
投稿日
投稿者
参照先
windows7 x64 hotfix専用CD起動せず
8549
: 2013/11/05(Tue) 23:37:46
ルーベンス

いつもこのソフトを使わせていただいております。
題記の剣ですが、バージョン0.99.5において、
windows7 x64 hotfix専用CDを作成し、
起動しようとしたのですが、『サポートされていない16ビットアプリケーション』というウィンドウが出ます。
内容は、『64ビットバージョンのWindowsで非互換性のため、プログラムまたは機能である"\??\EELEVATE.EXE"を開始または実行できません。ソフトウェア製造元に問い合わせて64ビット Windows互換バージョンが利用可能であるかどうか確認してください』
なのですが、どのようにすれば起動しますでしょうか。
こちらの操作ミスなのかもしれませんが、解決策をご教示いただければ幸いです。
以上、よろしくご検討願います。
タイトル
記事No
投稿日
投稿者
参照先
Re: windows7 x64 hotfix専用CD起動せず
8562
: 2013/12/08(Sun) 10:16:25
管理人

こんにちは。

> 内容は、『64ビットバージョンのWindowsで非互換性のため、プログラム
> または機能である"\??\EELEVATE.EXE"を開始または実行できません。
> ソフトウェア製造元に問い合わせて64ビット Windows互換バージョンが
> 利用可能であるかどうか確認してください』
> なのですが、どのようにすれば起動しますでしょうか。

おそらく、ELEVATE.EXEが破損しています。
もう一度、作成し直してみてください。
それでもダメなようであれば、もう一度、SP+メーカーをインストールし直して、
作成し直してみてください。
あと、CDメディアに焼く場合は、容量オーバーに気を付けてください。
タイトル
記事No
投稿日
投稿者
参照先
Re^2: windows7 x64 hotfix専用CD起動せず
8831
: 2015/04/29(Wed) 06:59:31
BS2

同じような症状が出ますので、お知らせします。
対象ファイルは
WAITIDLE.EXE
他、WindowsUpdateAgent-7.6-x64.exe、VCの各32bit版アップデート
などです。
上記のファイルでは、一度HOTFIXをかけたマシンに、上書きで再度実行させると確実に出るようです。
他のファイルでは、発生する条件が上記以外のときは本当
にランダムなためなかなか確定できません。
Windows7x64をインストールしたばかり、かつ、HOTFIXをまったくかけ
ていないマシンでは順調に完了することが多いのですが、まれに発生
することがあります。そのため、当方では、WAITIDLE.EXEもファイル
としては問題はないものと思わます。

とりあえず、デバッグモードをすべてつけて、確認してみます。
タイトル
記事No
投稿日
投稿者
参照先
解決できるといいですが。
8834
: 2015/05/01(Fri) 20:54:20
BS2

結局、デバッグモードではエラーは出てきていませんでした。

次の条件で発生しますので、使用法の問題となってしまいますね。
 DVD,CD、仮想DVDまたは仮想CD以外から起動させると発生します。
 例えば、ファイルをUSBメモリまたはHDD上にフォルダごと
  展開したところからSETUP.CMDを起動させた場合に発生します。もちろん、フォルダツリーは再現しておきますが。

総ファイル容量が4Gを超えると、USBなり、HDDに入れないと難しいので、なんとかなるとよいですね。
みなさんはこのような障害が発生していないでしょうか。

仮想化DVDから起動させた場合、再起動時に、マウントがわずかに遅れると、うまく続かせることができないことがあります。

なんとかなるでしょうか。
タイトル
記事No
投稿日
投稿者
参照先
Re: 解決しましたよ。
9030
: 2017/10/29(Sun) 10:36:23
BS2

2017年10月29日。
問題提起からかれこれ4年なのですね。
ほかのスレッドに解決策が書いてあるのかもしれませんが、とりあえず。

 ELEVATE.EXEの破損はもちろん発生していました。
しかし、実行ファイルが破損する場合、記録媒体の損傷か、または、
コピーしそこないぐらいしか原因がありません。
そのため、各段階でファイルを実行させて、状態を調べましたところ、
ISO化後に問題のエラーが発生するようになっていました。
各バージョンで同様でしたので、以下はv1.03での話とします。

 HOTFIXを作成する場合(おそらくはブータブルでも同じと思います。)
作業フォルダにmakeisoという、整理済みファイルを置くフォルダが作られています。
このフォルダ内ではまだ、エラーは発生しません。
しかし、ISOファイル化後、EXPLZHなどで、直接ISOファイルから実行させると、
エラーが発生します。また、ISOファイルを解凍させて、ELEVATE.EXEなどを抜き出して
みると、ELEVATE.exe以外でも、WUAGENT.EXEなどでもエラーが発生します。
 そのため、makeisoを直接、Cドライブ以外にフォルダごとコピーして、
SETUP.CMDを直接実行させると、エラーなく実行できました。

 よって、今回の原因はISO化時のなんらかのトラブルによるものと思われます。
特に、4.0Gを超えて作られるほどの容量であれば、頻度が高くなるので、
十分に疑われます。

 当分の対応としては、フォルダmakeisoをUSBメモリなりにフォルダごとコピーして
実行させるのが解決策でしょうか。

- WebForum -